After spending more time than I had trying to get XMind 3.2.1 running on my current laptop, I finally found a solution to this error:
"Version 1.4.2_03 of the JVM is not suitable for this product. Version 1.5 or greater is required."
Searching Google for various portions of that error message did not turn up anything useful. (Mostly a reply from Stephen Zhu back in _2009_ asking the user what OS they were on, nothing more.)
"Version 1.4.2_03 of the JVM is not suitable for this product.
Version 1.5 or greater is required."
(OS on my laptop: Microsoft Windows XP Service Pack 3 - 32 bit
Sun Java Runtime Environment 1.6.0.02 (Package v1.02)
I downloaded and installed C:\Program Files\Java\jdk1.7.0_01.
Neither Eclipse nor XMind would work _still!_
Finally searching for the solution to this error for Eclipse brought me to this:
Problem - "...when i run eclipse it gives "version 1.4.2_03 is not suitable for this product.1.5 or greater is required" message and does not run."
"Go to the directory where eclipse is installed and find a file called eclipse.ini.
Open it and add the following line
1.) You add that text before any -vmargs option that may be in that file.
2.) The -vm is on its own line and the path to javaw.exe is on its own line.
3.) You specify the full path to your JDK 1.5's javaw.exe "
That worked to get Eclipse running, but XMind still would not run.
I found that C:\Program Files\XMind\xmind.ini is very similar to eclipse.ini. I applied the same fix.
Now XMind is working.
Now I'm going back to some of these pages (_very_ old*) and posting this same answer. I hope the next guy or gal might be saved a little time and frustration!
Seems like an error like this that's been around in the installation since 2009 might have been fixed by now.
(Portable -- I saw there was an option for a portable version of XMind, but I can't find anywhere that says if the program is identical for features and functionality between the Windows and the Portable versions. If someone knows that, maybe they can add a useful answer.)